If the handle is a component why do you think it should not be clear that it is a component by avoiding changing its name?
However I’m always more convinced that this change is a good thing because if you read the code and you see a never meet before structure (for example the HandleComponent) you are 100% sure that it’s a component and you don’t need to search it in docs what it is.
Also by discarding this kind of addition the code became more and more cryptic where only the initial core developers know each part of the engine, and all other should check the doc each row of code.
Indeed I believe that this should be reflected to all the structures of the engine in order to have a clear map of what it is what.
Especially in an ECS architecture (where you have at least 3 time the same name for each part) programmed not using OO to me is necessary have this kind of naming rule otherwise the code will be unclear fast.
Then look at this scenario where you have other parts that doesn’t have a clear meaning like the Resources. For example you meet this:
let t = Texture::new();
What this line mean? I’m creating a component or a resource, or what??
let t = TextureRes::new()
is clear at the same way to both the last arrived dev and the older core dev, that it is a resource an nothing more.
So if the verbosity is something that you don’t like I want to propose to cut part of the “Component” word in order to have only “Comp” as suffix HandleComp, TransformComp, and so on… .