Vulkan extension and layer warnings

(Afonso Lage) #1

Hello folks!

I’m trying to learn amathyst but I get two warning that I can’t get rid of’em. Anothers erros and warnings gone away when I upgraded graphic driver and Vulkan, but those two are persistent:

[WARN][gfx_backend_vulkan] Unable to find extension: VK_KHR_wayland_surface
[WARN][gfx_backend_vulkan] Unable to find layer: VK_LAYER_LUNARG_standard_validation

How do I remove these?

I’m using Ubuntu 18.04 with a GT 710 (don’t blame me :frowning: )

(Jaynus) #2

Build in release mode. VK_LAYER_LUNARG_standard_validation is looking for the LunarG validation layers, which are only activated in debug mode. This isn’t an error at all, its just a warning to let you know you do not have the full validation layers installed (they are only used for debugging really).

2 Likes
(Afonso Lage) #3

Got it. thanks!